forum diagnostic auto
TPMS STORE / diagrostoto store
boutique ouverte

Soutenez le forum, merci


Dépenses 2015: 719€
Dépenses effectives: 719€

Dons 2015: 970€
Solde: +251€

Bien précisez votre speudo, ou m'envoyer un mail
mise à jour: 26/12/2015
Derniers sujets
» C4 Picasso turbo ou vanne EGR HS ?
par keryo Mar 21 Nov 2017 - 9:50

» 407 2.0 HDI RHR bloquée en régénération
par Teuteu0169 Mar 21 Nov 2017 - 8:04

» Problème EGR et effacement défauts ZAFIRA 2.2 DTI
par Teuteu0169 Dim 19 Nov 2017 - 15:11

» Probleme éclairage droit Ulysse/807 BSI
par loulou Sam 18 Nov 2017 - 12:56

» FORCEUR DE VALVE NP01 compatibilité Velsatis
par Calou10 Ven 17 Nov 2017 - 2:09

» questions sur le 1.9 dci 130 sans FAP
par jonathanv8 Mer 15 Nov 2017 - 9:56

» probleme fap 1.6 dci 130
par frederic Mar 14 Nov 2017 - 18:45

» echange moteur
par techabauto Sam 11 Nov 2017 - 16:45

» suspension hydraulique c5 x7
par heineken Lun 6 Nov 2017 - 23:23

» AIDE POUR MESSAGE D'ERREUR SUR FIAT DOBLO
par MJB972 Sam 4 Nov 2017 - 20:37

» Problème d'injecteur GFI sur AG SGI II
par pierrepoulpe Mer 1 Nov 2017 - 21:28

» Remettre un fap
par thierryledingue Mer 1 Nov 2017 - 12:54

» Ventilation habitacle permanente.
par Jean-Philippe Dim 29 Oct 2017 - 21:08

» Xsara Picasso 1.6 HDI 110 FAP Manque Puissance
par tuner25 Mar 24 Oct 2017 - 19:08

» ROUES NEIGE POUR 3008 A POSER
par Jean-Philippe Mer 18 Oct 2017 - 20:07

Rechercher
 
 

Résultats par :
 
Rechercher Recherche avancée
Qui est en ligne ?
Il y a en tout 142 utilisateurs en ligne :: 1 Enregistré, 1 Invisible et 140 Invités :: 2 Moteurs de recherche

PILOUF

Le record du nombre d'utilisateurs en ligne est de 537 le Lun 23 Jan 2017 - 18:52

Partagez | 
 

 ELM 327 ne fonctionne pas sur C5 ?

Voir le sujet précédent Voir le sujet suivant Aller en bas 
AuteurMessage
Invité
Invité



MessageSujet: ELM 327 ne fonctionne pas sur C5 ?   Ven 5 Nov 2010 - 9:12

Bonjour,

Je me permet d'écrire sur ce forum car je n'arrive pas à communiquer avec mon véhicule.

Mon véhicule est une CITROEN C5 1.6 HDI 110 Fap, année O7/2005.
Mon ELM 327 est une version USB v1.4

Je ne comprend pas pourquoi cela ne fonctionne pas, c'est un diesel supérieur à 2004 donc cela devrait être bon mais hélas non.
J'ai utilisé plusieurs logiciel dont OB2Diag_V1.00. Ce logiciel m'indique les messages suivants:
Citation :
- Version de l'OS : Windows XP
- Un Driver USB de la famille FTDI est installé.
- Un Driver COMPORT de la famille FTDI est installé.
- Ouverture du COMPORT réussi.COM3 to 9600 bauds
- Erreur : Pas de réponse de l'interface
- Ouverture du COMPORT réussi.COM3 to 38400 bauds
- Paramètres du COMPORT detéctés :COM3 to 38400
- Interface : ELM327 v1.4

- Tension du véhicule : 14.1V

- Optimisation de la communication étape 1/3 : Ok
- Optimisation de la communication étape 2/3 : Ok
- Optimisation de la communication étape 3/3 : Ok
- Attente de l'initialisation de l'ELM avec le calculateur. Attendre 10 secondes
- Connection au véhicule en cours
- PAS DE REPONSE
- Est ce que le contact du véhicule est mis?
- Est ce que votre véhicule est compatible OBD2?
- Appuyez sur Reset pour une nouvelle tentative
- Consulter la section FAQ du fichier d'aide pour plus de détails

Le logiciel scantools m'indique une erreur de communication avec l'ODB.

Quelqu'un a-t'il une idée? merci
Revenir en haut Aller en bas
grostoto
Admin
avatar

interface :
  • Elm
  • Lexia
  • Canclip
  • Opel
  • Lecteur défaut autonome

Messages : 4065
Date d'inscription : 05/11/2009
Age : 45

MessageSujet: Re: ELM 327 ne fonctionne pas sur C5 ?   Ven 5 Nov 2010 - 10:10

le contact est mis ?
Revenir en haut Aller en bas
http://www.diagnostic-auto.com
pierrepoulpe
découvreur
découvreur


interface :
  • Elm
  • Lexia

Messages : 48
Date d'inscription : 13/10/2010
Age : 35

MessageSujet: Re: ELM 327 ne fonctionne pas sur C5 ?   Ven 5 Nov 2010 - 10:50

+1 pour le contact, ce qui est déroutant, car la led du miens (bluetooth) s'allume même sans contact. Mais ca ne communique qu'avec le contact.
l'elm327 fonctionne très bien sur la mienne, certes essence, mais 2005 aussi, et ca faisait longtemps que les hdi savait parler l'obd
Revenir en haut Aller en bas
Invité
Invité



MessageSujet: Re: ELM 327 ne fonctionne pas sur C5 ?   Ven 5 Nov 2010 - 13:17

Oui, bien sûr. Le contact est mis. et dans le doute, j'ai même essayé moteur démarré.

Revenir en haut Aller en bas
pierrepoulpe
découvreur
découvreur


interface :
  • Elm
  • Lexia

Messages : 48
Date d'inscription : 13/10/2010
Age : 35

MessageSujet: Re: ELM 327 ne fonctionne pas sur C5 ?   Ven 5 Nov 2010 - 13:26

et tu as essayé sur une autre voiture?
(psa de même génération si possible, pour être sur que l'elm327 communique bien avec le même protocole (parmi les 5 de l'obd) que sur ta c5)
Si ca marche c'est que ton module 327 et le soft/pc fonctionne, donc soucis sur ton auto...
Revenir en haut Aller en bas
Invité
Invité



MessageSujet: Re: ELM 327 ne fonctionne pas sur C5 ?   Ven 5 Nov 2010 - 13:30

Non, je n'ai pas eu l'occasion d'essayer. Venant d'arriver récemment dans ma région, je ne connais personne qui me fera confiance pour bidouiller leur voiture, lol. Même si en fait, on change rien.

Il peut y avoir quoi comme soucis sur une auto?
Revenir en haut Aller en bas
pierrepoulpe
découvreur
découvreur


interface :
  • Elm
  • Lexia

Messages : 48
Date d'inscription : 13/10/2010
Age : 35

MessageSujet: Re: ELM 327 ne fonctionne pas sur C5 ?   Ven 5 Nov 2010 - 13:47

Je crois que c'est le BSI (boitier de servitude intelligent) qui assure la com obd, on peut pas exclure que la partie obd soit HS. Mais bon le module ELM327 a plus de chance d'être HS que ton BSI (j'espère pour toi)
Revenir en haut Aller en bas
Invité
Invité



MessageSujet: Re: ELM 327 ne fonctionne pas sur C5 ?   Ven 5 Nov 2010 - 13:57

Lol, j'espère aussi.
Bon je vais bien voir.

Merci pour toutes ces réponses.
Revenir en haut Aller en bas
Bx1993
confirmé
confirmé
avatar

interface :
  • Lexia

Messages : 164
Date d'inscription : 02/08/2010
Age : 43

MessageSujet: Re: ELM 327 ne fonctionne pas sur C5 ?   Ven 5 Nov 2010 - 16:30

Essaye en changeant le "debit" de tes port COM manuellement.
A priori le 9600 bauds ça marche pas et le 38400 est douteux! Essaye les autres.
Revenir en haut Aller en bas
pierrepoulpe
découvreur
découvreur


interface :
  • Elm
  • Lexia

Messages : 48
Date d'inscription : 13/10/2010
Age : 35

MessageSujet: Re: ELM 327 ne fonctionne pas sur C5 ?   Ven 5 Nov 2010 - 17:57

zth a écrit:

- Ouverture du COMPORT réussi.COM3 to 9600 bauds
- Erreur : Pas de réponse de l'interface
- Ouverture du COMPORT réussi.COM3 to 38400 bauds
- Paramètres du COMPORT detéctés :COM3 to 38400
- Interface : ELM327 v1.4

hmm, sceptique. Et quel paramètres tu veux essayer?
Si tu veux essayer un autre débit, il faut d'abord te connecter à 38400, envoyer un ordre à l'elm pour qu'il communique à une autre vitesse, puis te connecter à cette vitesse....
Revenir en haut Aller en bas
grostoto
Admin
avatar

interface :
  • Elm
  • Lexia
  • Canclip
  • Opel
  • Lecteur défaut autonome

Messages : 4065
Date d'inscription : 05/11/2009
Age : 45

MessageSujet: Re: ELM 327 ne fonctionne pas sur C5 ?   Ven 5 Nov 2010 - 18:21

il faut changer manuellement (dans les paramètres systèmes) le debit du port.

je ne pense pas qu'avec le soft d'elm tu puisses envoyer un ordre pour le modifier.
Revenir en haut Aller en bas
http://www.diagnostic-auto.com
pierrepoulpe
découvreur
découvreur


interface :
  • Elm
  • Lexia

Messages : 48
Date d'inscription : 13/10/2010
Age : 35

MessageSujet: Re: ELM 327 ne fonctionne pas sur C5 ?   Ven 5 Nov 2010 - 18:29

non mais en hyperterminal (ou équivalent) on peut modifier le baudrate
voire page 59 ici
http://elmelectronics.com/DSheets/ELM327DS.pdf
Revenir en haut Aller en bas
grostoto
Admin
avatar

interface :
  • Elm
  • Lexia
  • Canclip
  • Opel
  • Lecteur défaut autonome

Messages : 4065
Date d'inscription : 05/11/2009
Age : 45

MessageSujet: Re: ELM 327 ne fonctionne pas sur C5 ?   Ven 5 Nov 2010 - 18:43


je serai moins bète ce soir. study
Revenir en haut Aller en bas
http://www.diagnostic-auto.com
quatresyeux
participant
participant


interface :
  • Lexia
  • Aucune

Messages : 69
Date d'inscription : 01/11/2010
Age : 44

MessageSujet: Re: ELM 327 ne fonctionne pas sur C5 ?   Ven 5 Nov 2010 - 23:56

salut zth.
la mise en connection de outils de diag passe forcement par la bsi. cela m arrive parfois sur mon lexia 3 par contre je ne peut accerder a aucun caculateur du vehicule.
9 fois sur dix le probleme de com vient de l alimentation de la prise de diag via la bsi ( jéte un coup d oeil a tes fusibles ) as tu un attelage?
Revenir en haut Aller en bas
Invité
Invité



MessageSujet: Re: ELM 327 ne fonctionne pas sur C5 ?   Sam 6 Nov 2010 - 14:28

pierrepoulpe a écrit:
non mais en hyperterminal (ou équivalent) on peut modifier le baudrate
voire page 59 ici
http://elmelectronics.com/DSheets/ELM327DS.pdf

Peux-tu m'en dire plus sur comment effectuer la modification du baud rate ? Car je comprends un peu l'anglais mais là c'est du chinois.

quatresyeux a écrit:
9 fois sur dix le probleme de com vient de l alimentation de la prise de diag via la bsi ( jéte un coup d oeil a tes fusibles ) as tu un attelage?

Je n'ai pas d'attelage mais je vais vérifier au niveau de mes fusibles. Mais je n'ai rien remarquer qui ne fonctionnait plus sur ma C5.
Revenir en haut Aller en bas
quatresyeux
participant
participant


interface :
  • Lexia
  • Aucune

Messages : 69
Date d'inscription : 01/11/2010
Age : 44

MessageSujet: Re: ELM 327 ne fonctionne pas sur C5 ?   Sam 6 Nov 2010 - 19:12

re bonjour
as tu une communication avec les autres calculateur de ta voiture
Revenir en haut Aller en bas
Invité
Invité



MessageSujet: Re: ELM 327 ne fonctionne pas sur C5 ?   Dim 7 Nov 2010 - 16:25

Affaire résolue!

Avec un peu d'acharnement, je suis descendu avec mon pc et mon transfo 12v>230v.

J'ai utilisé le logiciel OB2Diag et j'ai testé tous les protocoles et j'en ai enfin trouvé un fonctionne avec mon véhicule.

Il s'agit du protocole ISO 14230-4 (fast init). Pour l'obliger à se mettre en place, il faut aller dans fichier > paramètres et de choisir le protocole.

Pour tous changements, il faut redémarrer le logiciel car sinon les changements ne sont pas pris en compte (c'est ce que je ne faisais pas au départ).

Merci pour votre aide.
Revenir en haut Aller en bas
Contenu sponsorisé




MessageSujet: Re: ELM 327 ne fonctionne pas sur C5 ?   

Revenir en haut Aller en bas
 
ELM 327 ne fonctionne pas sur C5 ?
Voir le sujet précédent Voir le sujet suivant Revenir en haut 
Page 1 sur 1

Permission de ce forum:Vous ne pouvez pas répondre aux sujets dans ce forum
Diagnostic automobile :: Diagnostic OBD :: ELM 327-
Sauter vers: